aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-29 13:42:38 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commite8a0323766a58fbe0db8ad7e655ee20851774aed (patch)
tree1db7130fabee488aad15a5bbef10f0d8ccd4a530 /meta-python/recipes-devtools/python
parent80aca3996342734e68a2d49ee0e29408c89cdadd (diff)
downloadmeta-openembedded-contrib-e8a0323766a58fbe0db8ad7e655ee20851774aed.tar.gz
python-versiontools: add recipes for python2 and python3
python-versiontools is a smart replacement for plain tuple used in __version__. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-versiontools.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-versiontools.inc b/meta-python/recipes-devtools/python/python-versiontools.inc
new file mode 100644
index 0000000000..b0e696f9c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-versiontools.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Smart replacement for plain tuple used in __version__"
+SECTION = "devel/python"
+HOMEPAGE = "https://launchpad.net/versiontools"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=3;endline=20;md5=02193721a38fd8a05a4ddeb7df8e294d"
+
+inherit pypi
+
+SRC_URI[md5sum] = "602b7db8eea30dd29a1d451997adf251"
+SRC_URI[sha256sum] = "a969332887a18a9c98b0df0ea4d4ca75972f24ca94f06fb87d591377e83414f6"
diff --git a/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb b/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb
new file mode 100644
index 0000000000..6bfe82e005
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-versiontools_1.9.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-versiontools.inc
diff --git a/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb b/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb
new file mode 100644
index 0000000000..e8d6b7ddaf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-versiontools_1.9.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-versiontools.inc