aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorCallaghan, Dan <dan.callaghan@opengear.com>2019-08-26 14:06:47 +1000
committerKhem Raj <raj.khem@gmail.com>2019-08-27 12:11:16 -0700
commita1cafabfce5535de0da01741723838ed4031c4f0 (patch)
treed583748444c057d515ccef86a02f4ca79e269866 /meta-python/recipes-devtools/python
parent5b4372c24c5b84af4ea1c6c8e9b821e5a4be4e2f (diff)
downloadmeta-openembedded-contrib-a1cafabfce5535de0da01741723838ed4031c4f0.tar.gz
python3-pystemd: add new recipe
This library provides wrappers around the systemd DBus API for manipulating systemd services. Signed-off-by: Dan Callaghan <dan.callaghan@opengear.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb
new file mode 100644
index 0000000000..89d718de68
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python bindings for interacting with systemd over DBus"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[md5sum] = "c5472be419f53f53f5da089ca8c981c0"
+SRC_URI[sha256sum] = "b1fc072c87e3766711f64caf86fd633dca393e20c8a0a37a5058dd70a21d8a14"
+
+DEPENDS = "systemd"
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+inherit pypi setuptools3 distro_features_check
+
+BBCLASSEXTEND = "native"