aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-19 12:23:14 +0900
committerKhem Raj <raj.khem@gmail.com>2019-09-19 00:09:43 -0700
commit6ded1171019ef764f48dce1d7124b72d2c44e62c (patch)
treefa04c1a5e453ab04cb3e431c0c86373cdc74214f /meta-python/recipes-devtools/python
parent5b98315d1955adcaf30c6d8589d6f39692e45a69 (diff)
downloadmeta-openembedded-contrib-6ded1171019ef764f48dce1d7124b72d2c44e62c.tar.gz
python-zipp: new recipe
Add new recipe python-zipp as it is RDEPEND of python-importlib-metadata. Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-zipp.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-zipp_0.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-zipp.inc b/meta-python/recipes-devtools/python/python-zipp.inc
new file mode 100644
index 0000000000..ba18f72161
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-zipp.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE = "https://github.com/jaraco/zipp"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "d4451a749d8a7c3c392a9edd1864a937"
+SRC_URI[sha256sum] = "3718b1cbcd963c7d4c5511a8240812904164b7f381b647143a89d3b98f9bcd8e"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
diff --git a/meta-python/recipes-devtools/python/python-zipp_0.6.0.bb b/meta-python/recipes-devtools/python/python-zipp_0.6.0.bb
new file mode 100644
index 0000000000..85949a2a6f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-zipp_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-zipp.inc
diff --git a/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
new file mode 100644
index 0000000000..b78663fd61
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-zipp.inc