aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-08-30 18:50:59 +0300
committerKhem Raj <raj.khem@gmail.com>2019-08-30 09:27:57 -0700
commit31a55b947d077c9ad9b61f30bf616ca32c425192 (patch)
treec215892c0431cd0fbe6965ac4c6e6f0d130ffe34 /meta-python/recipes-devtools/python
parent9d559933d7243969777625c7a66511fc43f1f2a0 (diff)
downloadmeta-openembedded-contrib-31a55b947d077c9ad9b61f30bf616ca32c425192.tar.gz
Remove bogus COMMON_LICENSE_DIR usage in LIC_FILES_CHKSUM
Using COMMON_LICENSE_DIR in LIC_FILES_CHKSUM of downloaded code is never the right thing to do, there must be some license information and that has to be checked instead. In several cases the claimed LICENSE was also incorrect. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-daemon_2.1.2.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio-tools.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-intervals.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pint.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-scrypt.inc2
9 files changed, 13 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
index ffb5beb570..002da046c4 100644
--- a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
+++ b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
@@ -8,8 +8,8 @@ RDEPENDS_${PN} = "python-docutils \
python-resource \
"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LICENSE = "Apache-2.0 & GPLv3"
+LIC_FILES_CHKSUM = "file://README;md5=2695c853a2cafc33e68a1d972889ebd2"
inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-grpcio-tools.inc b/meta-python/recipes-devtools/python/python-grpcio-tools.inc
index 91cc62f40f..1a15c48de0 100644
--- a/meta-python/recipes-devtools/python/python-grpcio-tools.inc
+++ b/meta-python/recipes-devtools/python/python-grpcio-tools.inc
@@ -5,8 +5,8 @@ SECTION = "devel/python"
DEPENDS_append = "${PYTHON_PN}-grpcio"
RDEPENDS_${PN} = "${PYTHON_PN}-grpcio"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-grpcio.inc b/meta-python/recipes-devtools/python/python-grpcio.inc
index 7d3675c455..c5762b26b2 100644
--- a/meta-python/recipes-devtools/python/python-grpcio.inc
+++ b/meta-python/recipes-devtools/python/python-grpcio.inc
@@ -17,8 +17,8 @@ RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
${PYTHON_PN}-six \
"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-intervals.inc b/meta-python/recipes-devtools/python/python-intervals.inc
index 1ecca3524b..a915e09f90 100644
--- a/meta-python/recipes-devtools/python/python-intervals.inc
+++ b/meta-python/recipes-devtools/python/python-intervals.inc
@@ -2,8 +2,8 @@ DESCRIPTION = "Interval arithmetic for Python"
HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
SECTION = "devel/python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab"
PYPI_PACKAGE := "python-intervals"
diff --git a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
index 9ad865d406..20ea018045 100644
--- a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
+++ b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
@@ -5,7 +5,7 @@ SECTION = "devel/python"
RDEPENDS_${PN} = "python-threading"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-pint.inc b/meta-python/recipes-devtools/python/python-pint.inc
index 53f7783934..2bc8e4ab63 100644
--- a/meta-python/recipes-devtools/python/python-pint.inc
+++ b/meta-python/recipes-devtools/python/python-pint.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
PYPI_PACKAGE := "Pint"
diff --git a/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-python/recipes-devtools/python/python-protobuf.inc
index ce95e66c98..5058d4bd31 100644
--- a/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "https://developers.google.com/protocol-buffers/"
SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc b/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc
index 9f07b6577a..bfcb023a2f 100644
--- a/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc
+++ b/meta-python/recipes-devtools/python/python-robotframework-seriallibrary.inc
@@ -1,7 +1,7 @@
SUMMARY = "Robot Framework test library for serial connection"
HOMEPAGE = "https://github.com/whosaysni/robotframework-seriallibrary"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
SRC_URI[md5sum] = "b7c9565d54c30df7cd3f3c0e29adffa3"
SRC_URI[sha256sum] = "256ad60fc0b7df4be44d82c302f5ed8fad4935cda99e4b45942e3c88179d1e19"
diff --git a/meta-python/recipes-devtools/python/python-scrypt.inc b/meta-python/recipes-devtools/python/python-scrypt.inc
index fef6ec976c..aff86a594f 100644
--- a/meta-python/recipes-devtools/python/python-scrypt.inc
+++ b/meta-python/recipes-devtools/python/python-scrypt.inc
@@ -1,6 +1,6 @@
DESCRIPTION = "Bindings for the scrypt key derivation function library"
LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=cb641bc04cda31daea161b1bc15da69f"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc"
HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-scrypt:"