aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-02-11 19:33:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:44:35 +0100
commit7f3176f6288516fb79378c3e6ec4c03fa1a8c98d (patch)
tree9b2e91f290c52751640596fb5a77c7d6f86d68c6 /meta-python/recipes-devtools/python
parent00ba7da845b96a15b42550d15a343f7bc36392f8 (diff)
downloadmeta-openembedded-contrib-7f3176f6288516fb79378c3e6ec4c03fa1a8c98d.tar.gz
recipes: blacklist recipes runtime depending on blacklisted recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.13.0.bb4
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
index 4523d9e30a..582d01d592 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.54.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools3
require python-pymisp.inc
+
+PNBLACKLIST[python3-pymisp] ?= "Runtime depends on blacklisted python3-pymisp"
+
+PNBLACKLIST[python3-pymisp] ?= "Runtime depends on blacklisted python3-pymisp-dev"
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
index 5e869b7883..bbfbfeb8a8 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
@@ -3,3 +3,7 @@ require python-requests.inc
# Add the runtime depends for selectors.py
RDEPENDS_${PN} += "${PYTHON_PN}-misc"
+
+PNBLACKLIST[python3-requests] ?= "Runtime depends on blacklisted python3-ndg-httpsclient"
+
+PNBLACKLIST[python3-requests] ?= "Runtime depends on blacklisted python3-requests-dev"