aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-05-14 17:09:52 +0800
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:27:55 -0700
commit550418d3b42a31944b6abf0188533eefcd2423af (patch)
tree3a4bc0a3e0d3674a9da07571b50d548c0f70971b /meta-python/recipes-devtools/python
parent716174e6a1ec3fcc7f59364fefa16cbc8c6fd736 (diff)
downloadmeta-openembedded-contrib-550418d3b42a31944b6abf0188533eefcd2423af.tar.gz
python3-django: upgrade 5.0.4 -> 5.0.6
Changelog: ============= - Fixed a bug in Django 5.0 that caused a crash of Model.save() when creating an instance of a model with a GeneratedField and providing a primary key - Fixed a compatibility issue encountered in Python 3.11.9+ and 3.12.3+ when validating email max line lengths with content decoded using the surrogateescape error handling scheme - Fixed a bug in Django 5.0 that caused a crash when applying migrations including alterations to GeneratedField such as setting db_index=True on SQLite - Allowed importing aprefetch_related_objects from django.db.models - Fixed a bug in Django 5.0 that caused a migration crash when a GeneratedField was added before any of the referenced fields from its expression definition - Fixed a bug in Django 5.0 that caused a migration crash when altering a GeneratedField referencing a renamed field - Fixed a bug in Django 5.0 where the querysets argument of GenericPrefetch was not required Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-django_5.0.6.bb (renamed from meta-python/recipes-devtools/python/python3-django_5.0.4.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_5.0.4.bb b/meta-python/recipes-devtools/python/python3-django_5.0.6.bb
index 3139ed4682..69b25742dc 100644
--- a/meta-python/recipes-devtools/python/python3-django_5.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-django_5.0.6.bb
@@ -1,7 +1,7 @@
require python-django.inc
inherit setuptools3
-SRC_URI[sha256sum] = "4bd01a8c830bb77a8a3b0e7d8b25b887e536ad17a81ba2dce5476135c73312bd"
+SRC_URI[sha256sum] = "ff1b61005004e476e0aeea47c7f79b85864c70124030e95146315396f1e7951f"
RDEPENDS:${PN} += "\
python3-sqlparse \