aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-15 09:17:07 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-17 13:41:44 -0800
commitcc9b5c659402846da68b24f3a29440124287f8e6 (patch)
tree9dfc887f3118d343accab329ff66322f07dc056a /meta-python/recipes-devtools/python
parentef0d1fe4b05d4e9a3bf9de0d3ab97010d1dff2a0 (diff)
downloadmeta-openembedded-contrib-cc9b5c659402846da68b24f3a29440124287f8e6.tar.gz
python-pyjks: add initial recipe for version 17.1.1
Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyjks.inc22
-rw-r--r--meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb2
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyjks.inc b/meta-python/recipes-devtools/python/python-pyjks.inc
new file mode 100644
index 0000000000..d866c56504
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjks.inc
@@ -0,0 +1,22 @@
+SUMMARY = "Pure-Python Java Keystore (JKS) library"
+DESCRIPTION = "PyJKS enables Python projects to load and manipulate\
+ Java KeyStore (JKS) data without a JVM dependency. PyJKS supports JKS,\
+ JCEKS, BKS and UBER (BouncyCastle) keystores."
+HOMEPAGE = "http://github.com/kurtbrose/pyjks"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9694d6cc724caf7f7386be88a4a81958"
+
+SRC_URI[md5sum] = "d53501e7c80d465969742bc6bee91d49"
+SRC_URI[sha256sum] = "709c44a303dd6b2464078ebeb677417e717818d4b3dc3844a462bef9d215dcc8"
+
+inherit pypi
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-javaobj-py3 \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyasn1-modules \
+ ${PYTHON_PN}-pycryptodome \
+ ${PYTHON_PN}-twofish\
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb b/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb
new file mode 100644
index 0000000000..ce99f28350
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyjks_17.1.1.bb
@@ -0,0 +1,2 @@
+require python-pyjks.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb b/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb
new file mode 100644
index 0000000000..8982fcebc3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyjks_17.1.1.bb
@@ -0,0 +1,2 @@
+require python-pyjks.inc
+inherit setuptools3