aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorRicardo Silva <rjpdasilva@gmail.com>2018-01-04 18:13:46 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:38:09 -0800
commitc06be20b249d023849726ee752b76816ccf2e9f4 (patch)
tree036fb3745034c846c6f5f026bd59d104eefeb7c7 /meta-python/recipes-devtools/python
parent582b5aae6f4d69a763c4c17014e07f1af8df5eea (diff)
downloadmeta-openembedded-contrib-c06be20b249d023849726ee752b76816ccf2e9f4.tar.gz
pycrypto: Add recipe to have support on python3
The pycrypto module sources can be used for both python2 and python3, but a recipe for python3 was missing, so add it. Additionally, since the sources (and thus the patches) are shared between both versions, move the SRC_URI (same on both recipes) to the common 'python-pycrypto.inc' file, to avoid duplication. Also, to use the same patch files for both python2 and python3 without having to duplicate them over 2 folders, change 'python-pycrypto.inc' so that FILESEXTRAPATHS is prepended with the 'python-pycrypto' local dir for both versions instead of having that dir named after the package name '${PN}'. The python3 recipe is basically the same as for python2, but using distutils3 instead. Signed-off-by: Ricardo Silva <rjpdasilva@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto.inc6
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb9
3 files changed, 14 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto.inc b/meta-python/recipes-devtools/python/python-pycrypto.inc
index fb2c17df1f..232cdb7116 100644
--- a/meta-python/recipes-devtools/python/python-pycrypto.inc
+++ b/meta-python/recipes-devtools/python/python-pycrypto.inc
@@ -3,12 +3,16 @@ HOMEPAGE = "http://www.pycrypto.org/"
LICENSE = "PSFv2"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-pycrypto:"
DEPENDS += " gmp"
inherit pypi autotools-brokensep
+SRC_URI += "file://cross-compiling.patch \
+ file://CVE-2013-7459.patch \
+ "
+
SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
diff --git a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
index 919f91ecb1..e13db01b7f 100644
--- a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
+++ b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -1,10 +1,6 @@
inherit distutils
require python-pycrypto.inc
-SRC_URI += "file://cross-compiling.patch \
- file://CVE-2013-7459.patch \
- "
-
# We explicitly call distutils_do_install, since we want it to run, but
# *don't* want the autotools install to run, since this package doesn't
# provide a "make install" target.
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
new file mode 100644
index 0000000000..02d634cb00
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
@@ -0,0 +1,9 @@
+inherit distutils3
+require python-pycrypto.inc
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils3_do_install
+}