aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-28 14:25:42 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-30 12:33:48 -0800
commita5203c37662f0c721d99a4ce9c76c075f4eae151 (patch)
treef4f1513acc6a3c61df04dc894ba1f3ec66df847c /meta-python/recipes-devtools/python
parentcf1f54761c5f19bd62a772e18f25911d579ae16b (diff)
downloadmeta-openembedded-contrib-a5203c37662f0c721d99a4ce9c76c075f4eae151.tar.gz
python-whoosh: add RDEPENDS to work on minimal python installs
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-whoosh.inc11
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb7
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-whoosh.inc b/meta-python/recipes-devtools/python/python-whoosh.inc
index 0a2cf3bf44..f43d8c1b0c 100644
--- a/meta-python/recipes-devtools/python/python-whoosh.inc
+++ b/meta-python/recipes-devtools/python/python-whoosh.inc
@@ -12,3 +12,14 @@ SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b4537
PYPI_PACKAGE = "Whoosh"
PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-subprocess \
+"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index 5d8af303c7..4a4e679fbb 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -1,2 +1,9 @@
inherit pypi setuptools3
require python-whoosh.inc
+
+# Requires _pydecimal.py which is in misc
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-selectors \
+"