aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-15 09:17:05 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-17 13:41:42 -0800
commit466c185a1abdcb896a0112328335ed4fe61a9222 (patch)
treea8d448ec23c42b2d21b4e0e5350b9e4ffb32ea1c /meta-python/recipes-devtools/python
parent108c11eade8e3b462d8b6e3dee2ebfa819b56a1f (diff)
downloadmeta-openembedded-contrib-466c185a1abdcb896a0112328335ed4fe61a9222.tar.gz
python-twofish: add initial recipe for version 0.3.0
Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-twofish.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-twofish_0.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-twofish.inc b/meta-python/recipes-devtools/python/python-twofish.inc
new file mode 100644
index 0000000000..79ab285e55
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-twofish.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Bindings for the Twofish implementation by Niels Ferguson"
+DESCRIPTION = "Bindings for the Twofish implementation by Niels Ferguson\
+ libtwofish-dev."
+HOMEPAGE = "http://github.com/keybase/python-twofish"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=33a63abf6d7567b1689d8ce69f00e43b"
+
+SRC_URI[md5sum] = "d7d22f16dc4ffa0e3ae2200654033abe"
+SRC_URI[sha256sum] = "b09d8bb50d33b23ff34cafb1f9209f858f752935c6a5c901efb92a41acb830fa"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python-twofish_0.3.0.bb
new file mode 100644
index 0000000000..85b021594b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-twofish_0.3.0.bb
@@ -0,0 +1,2 @@
+require python-twofish.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
new file mode 100644
index 0000000000..e593f6f212
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
@@ -0,0 +1,2 @@
+require python-twofish.inc
+inherit setuptools3