aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-01-15 09:17:04 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-17 13:41:42 -0800
commit108c11eade8e3b462d8b6e3dee2ebfa819b56a1f (patch)
treeac44bd4251a6cef891f98a100a0380cc134fa8e4 /meta-python/recipes-devtools/python
parent451a350011b89c52dac99a8de132c9fee51a5904 (diff)
downloadmeta-openembedded-contrib-108c11eade8e3b462d8b6e3dee2ebfa819b56a1f.tar.gz
python-pycryptodome: add initial recipe for version 3.4.7
Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome_3.4.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodome_3.4.7.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome.inc b/meta-python/recipes-devtools/python/python-pycryptodome.inc
new file mode 100644
index 0000000000..ecfcc9d803
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycryptodome.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Cryptographic library for Python"
+DESCRIPTION = "PyCryptodome is a self-contained Python package of low-level\
+ cryptographic primitives."
+HOMEPAGE = "http://www.pycryptodome.org"
+LICENSE = "PD & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=690cd8c71f0367a558f24fe53d943a2e"
+
+SRC_URI[md5sum] = "8744863c7d5980ae3f81c2e288701a61"
+SRC_URI[sha256sum] = "18d8dfe31bf0cb53d58694903e526be68f3cf48e6e3c6dfbbc1e7042b1693af7"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome_3.4.7.bb b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.7.bb
new file mode 100644
index 0000000000..c7701eb9f9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.7.bb
@@ -0,0 +1,2 @@
+require python-pycryptodome.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.7.bb b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.7.bb
new file mode 100644
index 0000000000..0c062dddf8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.7.bb
@@ -0,0 +1,2 @@
+require python-pycryptodome.inc
+inherit setuptools3