aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-10-16 00:55:36 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-18 09:49:37 -0700
commit22486627a4b016cfcbcf7f02b694a58eb0760505 (patch)
tree93b55a7481c9e2e710c496e229ecd8dcfd8bb3b0 /meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb
parentf5335a452714ed90cd1e52a79a961dd60e0ed42a (diff)
downloadmeta-openembedded-contrib-22486627a4b016cfcbcf7f02b694a58eb0760505.tar.gz
python3-yarl: update to 1.7.0
License-Update: copyright years updated. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb b/meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb
new file mode 100644
index 0000000000..acb4b4ac20
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.7.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
+
+SRC_URI[sha256sum] = "8e7ebaf62e19c2feb097ffb7c94deb0f0c9fab52590784c8cd679d30ab009162"
+
+SRC_URI += "file://run-ptest"
+
+PYPI_PACKAGE = "yarl"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-idna \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}