aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-26 20:03:47 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-27 11:54:04 -0800
commit24517fa18bd5541630dea78dcc4d12963355c76d (patch)
tree057e454eb0051ad555831fca6ad30f086fbff62d /meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb
parent80b096966edf94d1456cd524cd40d882ed9cdd45 (diff)
downloadmeta-openembedded-contrib-24517fa18bd5541630dea78dcc4d12963355c76d.tar.gz
python3-yarl: Upgrade 1.6.2 -> 1.6.3
Upgrade to release 1.6.3: - No longer loose characters when decoding incorrect percent-sequences (like %e2%82%f8). All non-decodable percent-sequences are now preserved. - Provide x86 Windows wheels. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb b/meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb
new file mode 100644
index 0000000000..01682a46d4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.6.3.bb
@@ -0,0 +1,28 @@
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
+
+SRC_URI[sha256sum] = "8a9066529240171b68893d60dca86a763eae2139dd42f42106b03cf4b426bf10"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+PYPI_PACKAGE = "yarl"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-idna \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}