aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-06-07 11:28:30 -0400
committerKhem Raj <raj.khem@gmail.com>2021-06-09 08:45:24 -0700
commitf3426371315ef7e19bed4347b2f071e02888dd98 (patch)
treef01468157630a542d7e8fc3a4c761b3f6d94cb7e /meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb
parentcf6014d1b5f75a74bde221a5c9a39152c40433c2 (diff)
downloadmeta-openembedded-contrib-f3426371315ef7e19bed4347b2f071e02888dd98.tar.gz
python3-yappi: fix ptests
- Add a patch to fix imports in unit tests - Add python3-gevent and python3-zopeinterface to ptest RDEPENDS - Sort ptest RDEPENDS alphabetically Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb b/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb
index 7c3f0fd4be..8a1aca21fe 100644
--- a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb
@@ -8,6 +8,7 @@ SRC_URI[sha256sum] = "a51d3e6e5563cc74b5bb82ed6e7bd44a9c1a7eae3d97e4d52e9465edb3
SRC_URI += " \
file://run-ptest \
+ file://0001-Fix-imports-for-ptests.patch \
"
inherit pypi setuptools3 ptest
@@ -19,9 +20,11 @@ RDEPENDS_${PN} += "\
"
RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-gevent \
${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-pytest \
${PYTHON_PN}-profile \
+ ${PYTHON_PN}-zopeinterface \
"
do_install_ptest() {