aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-04 13:10:05 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-06 10:27:35 -0700
commitf6438269ebe2631f96908e6b115e0dccf79600e5 (patch)
tree9692dc1f572a9e3662366e529988226b5017c9af /meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb
parent9dd2ade6278823497f3e2eb127de2dbd91058d4c (diff)
downloadmeta-openembedded-contrib-f6438269ebe2631f96908e6b115e0dccf79600e5.tar.gz
python3-xxhash: Upgrade 1.4.4 -> 2.0.0
Upgrade to release 2.0.0: - Require xxHash version >= v0.8.0 - Upgrade xxHash to v0.8.0 - XXH3 hashes: xxh3_64, xxh3_128, and their oneshot functions Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb b/meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb
new file mode 100644
index 0000000000..c5add103cd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xxhash_2.0.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
+
+SRC_URI[md5sum] = "010fda0427b621e5fe6930ad42511d88"
+SRC_URI[sha256sum] = "58ca818554c1476fa1456f6cd4b87002e2294f09baf0f81e5a2a4968e62c423c"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}