aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-26 13:22:14 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-27 11:54:04 -0800
commitb2d4c4fb9b41b82c416736accc20194dfb1a2fe0 (patch)
tree3b645f23786a25e42c73e916307f7656ad542518 /meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb
parenteed4c901afc1c5bb1e3ba687dfa29b612cfba2ab (diff)
downloadmeta-openembedded-contrib-b2d4c4fb9b41b82c416736accc20194dfb1a2fe0.tar.gz
python3-urllib3: Upgrade 1.25.11 -> 1.26.2
Upgrade to release 1.26.2: - NOTE: urllib3 v2.0 will drop support for Python 2. - Added support for HTTPS proxies contacting HTTPS servers - Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning should opt-in explicitly by setting ssl_version=ssl.PROTOCOL_TLSv1_1 Starting in urllib3 v2.0: Connections that receive a ``DeprecationWarning`` will fail - Deprecated Retry options Retry.DEFAULT_METHOD_WHITELIST, Retry.DEFAULT_REDIRECT_HEADERS_BLACKLIST and Retry(method_whitelist=...) in favor of Retry.DEFAULT_ALLOWED_METHODS, Retry.DEFAULT_REMOVE_HEADERS_ON_REDIRECT, and Retry(allowed_methods=...) Starting in urllib3 v2.0: Deprecated options will be removed - Added default User-Agent header to every request - Added urllib3.util.SKIP_HEADER for skipping User-Agent, Accept-Encoding, and Host headers from being automatically emitted with requests - Collapse transfer-encoding: chunked request data and framing into the same socket.send() call - Send http/1.1 ALPN identifier with every TLS handshake by default - Properly terminate SecureTransport connections when CA verification fails - Don't emit an SNIMissingWarning when passing server_hostname=None to SecureTransport - Disabled requesting TLSv1.2 session tickets as they weren't being used by urllib3 - Suppress BrokenPipeError when writing request body after the server has closed the socket - Wrap ssl.SSLError that can be raised from reading a socket (e.g. "bad MAC") into an urllib3.exceptions.SSLError - Fixed an issue where two User-Agent headers would be sent if a User-Agent header key is passed as bytes License-Update: Update copyright date Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb b/meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb
new file mode 100644
index 0000000000..fcd6709017
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-urllib3_1.26.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
+
+SRC_URI[sha256sum] = "19188f96923873c92ccb987120ec4acaa12f0461fa9ce5d3d0772bc965a39e08"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-certifi \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-threading \
+"
+
+CVE_PRODUCT = "urllib3"
+
+BBCLASSEXTEND = "native nativesdk"