aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:41 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commit21fe4d2290be9200222867c1fe63738edf150c7c (patch)
tree4766773dc19ac8c37030fadcd59341d5bf38305c /meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb
parent4b46c014fbfc4a9978652b97d9fa8a7c4c4597ce (diff)
downloadmeta-openembedded-contrib-21fe4d2290be9200222867c1fe63738edf150c7c.tar.gz
python3-uritemplate: add recipe for 3.0.1
This recipe originally comes from meta-openstack, but it's dependency-less, so it may as well live here and get wider use. meta-openstack is MIT-licensed, so the recipe is compatible. Also bump the version to 3.0.1, from the 3.0.0 currently in meta-openstack. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb b/meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb
new file mode 100644
index 0000000000..952e954c50
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-uritemplate_3.0.1.bb
@@ -0,0 +1,14 @@
+# This recipe is originally from meta-openstack:
+# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python3-uritemplate_3.0.0.bb?h=master
+
+SUMMARY = "Simple python library to deal with URI Templates."
+AUTHOR = "Ian Cordasco"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0f6d769bdcfacac3c1a1ffa568937fe0"
+
+SRC_URI[md5sum] = "869fb44fbd56713490db7272eb36c8ae"
+SRC_URI[sha256sum] = "5af8ad10cec94f215e3f48112de2022e1d5a37ed427fbd88652fa908f2ab7cae"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"