aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-13 11:59:09 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-16 23:11:58 -0700
commit60ae1e819a19d6fc55a756fae954efa4e030bf98 (patch)
treee4bfd5b68bb8c52433f6b8cb1836ffe132841e24 /meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb
parentc32f491964f87b62100b710e5e3a417d2e54c76e (diff)
downloadmeta-openembedded-contrib-60ae1e819a19d6fc55a756fae954efa4e030bf98.tar.gz
python3-ujson: Upgrade 3.2.0 -> 4.0.1
Upgrade to release 4.0.1: - Fix UnicodeDecodeError on arm64/aarch64 - Add support for Python 3.9 - Build wheels for Python 3.9 - Drop support for EOL Python 3.5 - Fix indent and add test case - Update code samples in README Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb b/meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb
new file mode 100644
index 0000000000..2475306f91
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_4.0.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
+
+SRC_URI[md5sum] = "c8030a62912c3be18ff99fa5b25258b8"
+SRC_URI[sha256sum] = "26cf6241b36ff5ce4539ae687b6b02673109c5e3efc96148806a7873eaa229d3"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytz \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"