aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-24 17:50:02 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:34:20 -0700
commita796bb5e88cfa64887ee64aa067157bfe038d436 (patch)
treece172a9cf2feeb74d33f4d0e2e22144114039580 /meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb
parent4876bdb197c2f816b6de04dff4e987eda03935fa (diff)
downloadmeta-openembedded-contrib-a796bb5e88cfa64887ee64aa067157bfe038d436.tar.gz
python3-typing-extensions: Upgrade 3.7.4.2 -> 3.7.4.3
Upgrade to release 3.7.4.3: - Add SupportsIndex, added in Python 3.8 - Make tests for Annotated work with Python 3.9 - Add PEP 613 TypeAlias to typing_extensions - Add tox.ini for typing_extensions - Remove extra 'use' in readme Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb b/meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb
new file mode 100644
index 0000000000..8ef15fab79
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typing-extensions_3.7.4.3.bb
@@ -0,0 +1,13 @@
+HOMEPAGE = "https://github.com/python/typing"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f"
+
+# The name on PyPi is slightly different.
+PYPI_PACKAGE = "typing_extensions"
+
+SRC_URI[md5sum] = "5fcbfcb22e6f8c9bf23fb9f8e020f6ee"
+SRC_URI[sha256sum] = "99d4073b617d30288f569d3f13d2bd7548c3a7e4c8de87db09a9d29bb3a4a60c"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"