aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-08-12 09:06:42 +0000
committerKhem Raj <raj.khem@gmail.com>2019-08-12 09:11:01 -0700
commit8b4b7567a69610b9e04acbd1c9a2b8e1d16f37f8 (patch)
tree480d914394b4feabc0b18c76d7ba7f50c49d652b /meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
parent7cede6b863fc0de245b4b7f0071ac38d2059b0af (diff)
downloadmeta-openembedded-contrib-8b4b7567a69610b9e04acbd1c9a2b8e1d16f37f8.tar.gz
python3-twofish: Fix missing return statements in module stubs
* fixes build with -Werror=return-type twofish.c: In function 'init_twofish': twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type] 45 | PyMODINIT_FUNC init_twofish(void) { } | ^~~~~~~~~~~~~~ twofish.c: In function 'PyInit__twofish': twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type] 46 | PyMODINIT_FUNC PyInit__twofish(void) { } | ^~~~~~~~~~~~~~ cc1: some warnings being treated as errors Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
index e593f6f212..7b8eb2ef0f 100644
--- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
@@ -1,2 +1,4 @@
require python-twofish.inc
inherit setuptools3
+
+SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch"