aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-07 17:32:03 +0300
committerTrevor Gamblin <trevor.gamblin@windriver.com>2021-04-08 08:54:52 -0400
commitdce8ef5add115eb1ecdf39d547e5c566a92b2bd6 (patch)
treead1a47b366cc8270b6a3ecf7985b8d1b90bc6948 /meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb
parentbe5b722809c29acef2de0c0978659692483aa8aa (diff)
downloadmeta-openembedded-contrib-dce8ef5add115eb1ecdf39d547e5c566a92b2bd6.tar.gz
python3-transitions: Upgrade 0.8.7 -> 0.8.8
Upgrade to release 0.8.8: - AsyncMachine does not remove models when remove_models is called - Introduce try/except for finalize callbacks in Machine and HierachicalMachine. Thus, errors occurring in finalize callbacks will be suppressed and only the original error will be raised. - Show references in graphs and markup. Introduce MarkupMachine.format_references to tweak reference formatting - Introduce Machine.on_exception to handle raised exceptions in callbacks - Machine.get_triggers now supports State and Enum as arguments - NestedState and HierachicalMachine.add_states now accept (lists of) states and enums as initial parameter Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb b/meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb
new file mode 100644
index 0000000000..2b82df5814
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-transitions_0.8.8.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A lightweight, object-oriented Python state machine implementation with many extensions."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=baac7be1f4c17620df74188e23da6d47"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "e7a86b31a161a76133f189b3ae9dad2755a80ea4c1e0eee1805648d021fb677d"
+
+RDEPENDS_${PN} += "python3-six"