aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-15 11:16:25 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-19 17:14:08 -0700
commit8288281e3b35674e8a76b600cb114e328c3ed94f (patch)
treed94c932318ec2a83d6d3f84e270ef43e6e62f147 /meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb
parentdadaed39c981f360609d6c4fc53a9ed6568adf46 (diff)
downloadmeta-openembedded-contrib-8288281e3b35674e8a76b600cb114e328c3ed94f.tar.gz
python3-trafaret-config: Add recipe version 2.0.2
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb b/meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb
new file mode 100644
index 0000000000..b0f7548e4c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-trafaret-config_2.0.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "This is a wrapper that loads yaml and checks config using trafaret while keeping track of actual lines of file where error has happened."
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=98;endline=106;md5=a15308789c3b7d0f3ef36b69048423e4"
+
+SRC_URI[sha256sum] = "440b6b49e5e975f9a640a2519abb2feddd96eb2aeb1715f87f947a7a079f20be"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-trafaret \
+ ${PYTHON_PN}-pyyaml \
+"
+
+BBCLASSEXTEND = "native nativesdk"