aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-08-06 05:51:12 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:37:42 -0700
commit6be40a77ca1238e97688f1662da90f74ea8a9b16 (patch)
tree842995f4f542d49fc3a6cd43d47e0f8add5b1cf0 /meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb
parentf627883d190ddc04a5956f0c006d6654ad31279c (diff)
downloadmeta-openembedded-contrib-6be40a77ca1238e97688f1662da90f74ea8a9b16.tar.gz
python3-tqdm: upgrade 4.61.2 -> 4.62.0
asyncio.gather API consistency with stdlib (#1212) fix shutdown exception (#1209 <- #1198) misc build framework updates (#1209) add GH Sponsors & merch links Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb
new file mode 100644
index 0000000000..f9b530d652
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.62.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=59e4271a933d33edfe60237db377a14b"
+
+SRC_URI[sha256sum] = "3642d483b558eec80d3c831e23953582c34d7e4540db86d9e5ed9dad238dabc6"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-logging \
+ python3-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"