aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-11 14:44:26 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commit7c43059f2efc9a744365b8bf44dc17a60a5dc6ff (patch)
treea8ea58b61b54da1c42734fb38b6082925f7b5f32 /meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb
parent03c859c0e4de3a77ac7b9bc1c234a637c5939e1d (diff)
downloadmeta-openembedded-contrib-7c43059f2efc9a744365b8bf44dc17a60a5dc6ff.tar.gz
python3-tqdm: Upgrade 4.48.0 -> 4.48.2
Upgrade to release 4.48.2: - fix notebook formatting - fix ANSI escape codes breaking tqdm.write - fix long-lived strongref - fix cli --version crash on missing git/refs/heads - fix contrib.tenumerate ignoring total - fix potential deep => shallow kwargs copy issues - improve notebook display for unknown total - make asyncio inherit from std rather than auto - make auto multi-inherit from autonotebook, asyncio on Python3.5+ - misc documentation & examples updates - mention docker-compose requirements - misc linting & tidy - misc minor testing framework updates Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb
new file mode 100644
index 0000000000..8314680953
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.48.2.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=7ea57584e3f8bbde2ae3e1537551de25"
+
+SRC_URI[md5sum] = "d29c836d74d2f2ec6a10d052937f7371"
+SRC_URI[sha256sum] = "564d632ea2b9cb52979f7956e093e831c28d441c11751682f84c86fc46e4fd21"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"