aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-02 12:03:02 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-04 11:10:11 -0800
commit9610511f353667a1439381d7945e1a14b2aadc74 (patch)
treefc1b4843a15265e1e42f50d660accfabb5e5e6d8 /meta-python/recipes-devtools/python/python3-tornado_6.1.bb
parentb32e97a4511614bdba62e27762be61ae3fa02185 (diff)
downloadmeta-openembedded-contrib-9610511f353667a1439381d7945e1a14b2aadc74.tar.gz
python3-tornado: Upgrade 6.0.4 -> 6.1
Upgrade to release 6.1: - Windows support has been improved. Tornado is now compatible with the proactor event loop (which became the default in Python 3.8) by automatically falling back to running a selector in a second thread. This means that it is no longer necessary to explicitly configure a selector event loop, although doing so may improve performance. This does not change the fact that Tornado is significantly less scalable on Windows than on other platforms. - Binary wheels are now provided for Windows, MacOS, and Linux (amd64 and arm64). - This is the last release of Tornado to support Python 3.5. Future versions will require Python 3.6 or newer License-Update: Checksum change, lisense remains "Apache-2.0" Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tornado_6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_6.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.1.bb b/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
new file mode 100644
index 0000000000..89ff715b65
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
+DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
+By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
+polling, WebSockets, and other applications that require a long-lived connection to each user."
+HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "f324f5e7607798552359d6ab054c4321"
+SRC_URI[sha256sum] = "33c6e81d7bd55b468d2e793517c909b139960b6c790a60b7991b9b6b76fb9791"
+
+inherit pypi setuptools3
+
+# Requires _compression which is currently located in misc
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
+ ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
+
+RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
+
+PACKAGES =+ "\
+ ${PN}-test \
+"
+
+FILES_${PN}-test = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/*/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
+"