aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-11 14:44:27 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commit661e01fba65054cd9f7c9c517270e7d03e029ef6 (patch)
tree84eea6dfde4097e701515680e14314dfe980fb45 /meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb
parent7c43059f2efc9a744365b8bf44dc17a60a5dc6ff (diff)
downloadmeta-openembedded-contrib-661e01fba65054cd9f7c9c517270e7d03e029ef6.tar.gz
python3-sympy: Upgrade 1.6.1 -> 1.6.2
Upgrade to release 1.6.2: - Fixed a bug that made matrix operations fail in a multithreaded application - Using factor with the extension argument no longer hangs in some cases - Calling preview with viewer="file" no longer looks for a file executable (a regression in 1.6.0) - The deprecation of calling preview with viewer="StringIO" is now expired instead of forgotten (a regression in 1.6.0) - intersphinx links to :mod:`sympy` no longer point to the documentation for Immutable Matrices Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb b/meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb
new file mode 100644
index 0000000000..428b40c3b7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sympy_1.6.2.bb
@@ -0,0 +1,16 @@
+# This recipe is adapted from one in meta-jupyter:
+# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-sympy_1.1.bb
+
+SUMMARY = "Computer algebra system (CAS) in Python"
+HOMEPAGE = "https://pypi.org/project/sympy/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ebb06e9df8f57522b72d0edb0fcf83d4"
+
+SRC_URI[md5sum] = "50d6b69b1de36b757484b9ff833a9e0a"
+SRC_URI[sha256sum] = "1cfadcc80506e4b793f5b088558ca1fcbeaec24cd6fc86f1fdccaa3ee1d48708"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-mpmath"
+
+BBCLASSEXTEND = "native nativesdk"