aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:40 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commit4b46c014fbfc4a9978652b97d9fa8a7c4c4597ce (patch)
tree86b1df3ac88380c5a06ec004ba8502b8475123b8 /meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb
parentbde96455036076de7803b7b9e617e24f0e2c1a11 (diff)
downloadmeta-openembedded-contrib-4b46c014fbfc4a9978652b97d9fa8a7c4c4597ce.tar.gz
python3-sympy: add recipe for 1.5.1
This recipe is adapted from one in meta-jupyter, which is also MIT-licensed. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb b/meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb
new file mode 100644
index 0000000000..c0c382a518
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sympy_1.5.1.bb
@@ -0,0 +1,16 @@
+# This recipe is adapted from one in meta-jupyter:
+# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-sympy_1.1.bb
+
+SUMMARY = "Computer algebra system (CAS) in Python"
+HOMEPAGE = "https://pypi.org/project/sympy/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=611b41534dbf5aa01d7c827bf667ef66"
+
+SRC_URI[md5sum] = "b11b310c3e1642bf66e51038cb3c0021"
+SRC_URI[sha256sum] = "d77901d748287d15281f5ffe5b0fef62dd38f357c2b827c44ff07f35695f4e7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-mpmath"
+
+BBCLASSEXTEND = "native nativesdk"