aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:31 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commitb5eb11e600b6ca663ddf42b0b939ded72abf748a (patch)
tree8590babd5fda0e885658159b41db1eeaae2e365d /meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb
parentf74d2ee792590cccc89ca22fb091a7c9058129bc (diff)
downloadmeta-openembedded-contrib-b5eb11e600b6ca663ddf42b0b939ded72abf748a.tar.gz
python-supervisord: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb32
1 files changed, 30 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb
index d29e1d6b66..56ab27e0f6 100644
--- a/meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-supervisor_4.1.0.bb
@@ -1,2 +1,30 @@
-inherit setuptools3
-require python-supervisor.inc
+SUMMARY = "Supervisor: A Process Control System"
+DESCRIPTION = "\
+Supervisor is a client/server system that allows its users \
+to monitorand control a number of processes on UNIX-like \
+operating systems."
+HOMEPAGE = "https://github.com/Supervisor/supervisor"
+LICENSE = "BSD-4-Clause"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
+
+SRC_URI[md5sum] = "ecea94eedc70ba5127fdeb0665bcca0d"
+SRC_URI[sha256sum] = "2dc86fe0476e945e61483d614ceb2cf4f93b95282eb243bdf792621994360383"
+
+PYPI_PACKAGE = "supervisor"
+inherit pypi systemd setuptools3
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-meld3 \
+"
+
+SRC_URI += "file://supervisord.conf \
+ file://supervisor.service \
+ "
+SYSTEMD_SERVICE_${PN} = "supervisor.service"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/supervisor
+ install -d ${D}${systemd_system_unitdir}
+
+ install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
+ install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
+}