aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-12-18 23:47:44 +0200
committerKhem Raj <raj.khem@gmail.com>2020-12-21 17:53:15 -0800
commitb8241bb074c7a8c9ba100ade51133377a75818da (patch)
tree21330882ae1756b2e36be2040cae3c14d1cc7cda /meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb
parent4a0ee53848c8ba58db520c17e4208e4430b41463 (diff)
downloadmeta-openembedded-contrib-b8241bb074c7a8c9ba100ade51133377a75818da.tar.gz
python3-stevedore: Upgrade 3.2.2 -> 3.3.0
Upgrade to release 3.3.0: - Use py3 as the default runtime for tox - Adding pre-commit - Fix cache dir flooding when running from /tmp - Add Python3 wallaby unit tests - Update master for stable/victoria Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb b/meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb
new file mode 100644
index 0000000000..5103717182
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-stevedore_3.3.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Manage dynamic plugins for Python applications"
+HOMEPAGE = "https://docs.openstack.org/stevedore/latest/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[sha256sum] = "3a5bbd0652bf552748871eaa73a4a8dc2899786bc497a2aa1fcb4dcdb0debeee"
+
+DEPENDS += "${PYTHON_PN}-pbr-native"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
+
+BBCLASSEXTEND = "native"