aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-23 12:51:26 +0300
committerArmin Kuster <akuster808@gmail.com>2020-07-01 08:01:41 -0700
commit41f84f6ea89faf0f6bd33cd38a9d141df36e598d (patch)
treee30e04e5c5ef9b854e072501c2bb87a1db1d7ab9 /meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb
parentc5f960590436dc6f908b3b7bbeedcfba7e7df97a (diff)
downloadmeta-openembedded-contrib-41f84f6ea89faf0f6bd33cd38a9d141df36e598d.tar.gz
python3-sqlalchemy: Upgrade 1.3.12 -> 1.3.17
Upgrade to release 1.3.17: - orm Bug fixes - orm Added an accessor ColumnProperty.Comparator.expressions which provides access to the group of columns mapped under a multi-column ColumnProperty attribute. - orm Introduce _orm.relationship.sync_backref flag in a relationship to control if the synchronization events that mutate the in-Python attributes are added. This supersedes the previous change #5149, which warned that viewonly=True relationship target of a back_populates or backref configuration would be disallowed. - engine Bug fixes - schema Bug fixes - schema Add comment attribute to _schema.Column __repr__ method. The year in LICENSE has been updated so LIC_FILES_CHKSUM was changed. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 5fef53b9989767dae9288274df871639e7c1c4a1) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb
new file mode 100644
index 0000000000..b9c58e5b6a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.17.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c19467890539ff718c00a019c9c7a7b2"
+
+SRC_URI[md5sum] = "478214152b9293bf5652815d7312c890"
+SRC_URI[sha256sum] = "156a27548ba4e1fed944ff9fcdc150633e61d350d673ae7baaf6c25c04ac1f71"
+
+PYPI_PACKAGE = "SQLAlchemy"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+"