aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-19 19:13:02 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-22 09:18:56 -0700
commit059b52fe660193c57feff16565de2428b0d5657a (patch)
tree07bb6733d7e66d2e555ac8f7765100d5894291e7 /meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb
parent484cac1e4e8b5c1ee974b8ab35b74a0234e29f36 (diff)
downloadmeta-openembedded-contrib-059b52fe660193c57feff16565de2428b0d5657a.tar.gz
python3-soupsieve: Upgrade 2.2 -> 2.2.1
Upgrade to release 2.2.1: - Fix an issue with namespaces when one of the keys is self. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb
new file mode 100644
index 0000000000..93ef04f145
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.2.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "CSS selector library for python-beautifulsoup4"
+HOMEPAGE = "https://github.com/facelessuser/soupsieve"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=33c3a77def9b3ad83e01c65bdcc1af67"
+
+SRC_URI[sha256sum] = "052774848f448cf19c7e959adf5566904d525f33a3f8b6ba6f6f8f26ec7de0cc"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-beautifulsoup4 \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"