aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-04-03 21:42:42 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:45:54 -0700
commit28f92d97568ed6087f5d0a6bc1306481ac34ef19 (patch)
tree15871144e1d21515e12a8f98936175a263cf889c /meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb
parent9bc31fb5715fce63918f0f5ba2b77435a52a205b (diff)
downloadmeta-openembedded-contrib-28f92d97568ed6087f5d0a6bc1306481ac34ef19.tar.gz
python3-socketio: upgrade 4.4.0 -> 4.5.1
See full changelog https://github.com/miguelgrinberg/python-socketio/blob/master/CHANGES.md Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb b/meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb
new file mode 100644
index 0000000000..54ecbbaa08
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-socketio_4.5.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Socket.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-socketio"
+
+SRC_URI[md5sum] = "3dbd0a2ebcf34632f67327b665cbb951"
+SRC_URI[sha256sum] = "149b98c33f8c3d09273fb4ebeb83781e4dc9411b56b27d9f058bec1bd1ed74b7"
+
+PACKAGECONFIG ?= "asyncio_client client"
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-engineio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-attrs \
+ "