aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-04-06 11:31:48 +0300
committerKhem Raj <raj.khem@gmail.com>2020-04-06 08:29:49 -0700
commit665b7360cbfc9b79c036c5946bdb5ad308604be1 (patch)
treeab1fcd13dc0e37235ca0607c4180787362e1bbfa /meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb
parentb7d55818f48924e8ba684c96a716f5d0a65ad5ca (diff)
downloadmeta-openembedded-contrib-665b7360cbfc9b79c036c5946bdb5ad308604be1.tar.gz
python-smbus2: Add new recipe
Drop-in replacement for smbus-cffi/smbus-python in pure Python. It is another implementation of the python-smbus package. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb b/meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb
new file mode 100644
index 0000000000..dee70a03f5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-smbus2_0.3.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Drop-in replacement for smbus-cffi/smbus-python in pure Python"
+DESCRIPTION = "smbus2 is a drop-in replacement for smbus-cffi/smbus-python in pure Python"
+HOMEPAGE = "https://github.com/kplindegaard/smbus2"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "d5ed5acc889b4770a84cc932853ed20a"
+SRC_URI[sha256sum] = "210e66eebe4d0b1fe836b3ec2751841942e1c4918c0b429b20a0e20a222228b4"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "smbus2"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-ctypes ${PYTHON_PN}-fcntl"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-fcntl \
+"