aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-22 13:49:00 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-23 10:26:48 -0700
commit16ba72d3050d84c3ff13bb9d5d594cf43a407f2a (patch)
tree6af98e3d0f30815297df040a1ecaea570c8556e6 /meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb
parent8b27915e26980588baca95d8048b9ba8beaad182 (diff)
downloadmeta-openembedded-contrib-16ba72d3050d84c3ff13bb9d5d594cf43a407f2a.tar.gz
python3-simplejson: Upgrade 3.17.0 -> 3.17.2
Upgrade to release 3.17.2: * Added arm64 to build matrix and reintroduced manylinux wheels * No more bdist_wininst builds per PEP 527 * Minor grammatical issue fixed in README Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb
new file mode 100644
index 0000000000..cab0da6a15
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.17.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
+
+SRC_URI[md5sum] = "27fba3bc75a32318bd3b163b8a31aa7e"
+SRC_URI[sha256sum] = "75ecc79f26d99222a084fbdd1ce5aad3ac3a8bd535cd9059528452da38b68841"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+"
+
+PACKAGES =+ "${PN}-tests"
+RDEPENDS_${PN}-tests = "${PN} ${PYTHON_PN}-unittest"
+FILES_${PN}-tests+= " \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tool.py* \
+"
+
+BBCLASSEXTEND = "native nativesdk"