aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sh_1.14.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-17 14:11:25 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-19 09:16:54 -0700
commit269880d81da56d3cf7321a8a359db54c4c3d20a7 (patch)
treee263e198842075b2a20b2e602f037b057d7fdb3d /meta-python/recipes-devtools/python/python3-sh_1.14.2.bb
parent67f9550be7cee343f31f508414f5e0d814bb3844 (diff)
downloadmeta-openembedded-contrib-269880d81da56d3cf7321a8a359db54c4c3d20a7.tar.gz
python3-sh: Upgrade 1.14.1 -> 1.14.2
Upgrade to release 1.14.2: - bugfix where setting _ok_code to not include 0, but 0 was the exit code Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sh_1.14.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sh_1.14.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sh_1.14.2.bb b/meta-python/recipes-devtools/python/python3-sh_1.14.2.bb
new file mode 100644
index 0000000000..5728ccf252
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sh_1.14.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[sha256sum] = "9d7bd0334d494b2a4609fe521b2107438cdb21c0e469ffeeb191489883d6fe0d"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+"