aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-01 15:04:18 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-03 15:15:24 -0700
commit22be5f7940065d6412fdc49f2e29e9d172dd6ab1 (patch)
tree71ea3ce1ce5c4243a9e4b95e5e7d99bf792e330b /meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb
parent636929a3564e6d63130f726cd09c7927018f98c6 (diff)
downloadmeta-openembedded-contrib-22be5f7940065d6412fdc49f2e29e9d172dd6ab1.tar.gz
python3-serpent: Upgrade 1.28 -> 1.30.2
Upgrade to release 1.30.2. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb b/meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb
new file mode 100644
index 0000000000..64edff76ba
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.30.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Serialization based on ast.literal_eval"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5271c65b7cf83bd28055e592c2d14667"
+
+SRC_URI[md5sum] = "cbef4f9c88f88c38195d11a0363a095f"
+SRC_URI[sha256sum] = "72753820246a7d8486e8b385353e3bbf769abfceec2e850fa527a288b084ff7a"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytz \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+"