aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-semver_2.13.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-21 11:25:29 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-22 22:16:49 -0700
commitcb705407176d5338d177e60d87a72585fa16a74f (patch)
tree234907e119b331f8a47c5c4fae24672304c75cd0 /meta-python/recipes-devtools/python/python3-semver_2.13.0.bb
parenta2e4d6ad22789fbafe1990f0dcc3e342ca0e7213 (diff)
downloadmeta-openembedded-contrib-cb705407176d5338d177e60d87a72585fa16a74f.tar.gz
python3-semver: Upgrade 2.10.2 -> 2.13.0
Upgrade to release 2.13.0: - Document how to create subclass from VersionInfo - Ensure equal versions have equal hashes. Version equality means for semver, that major, minor, patch, and prerelease parts are equal in both versions you compare. The build part is ignored. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-semver_2.13.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-semver_2.13.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver_2.13.0.bb b/meta-python/recipes-devtools/python/python3-semver_2.13.0.bb
new file mode 100644
index 0000000000..8c7c424c6d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-semver_2.13.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Python module for Semantic Versioning"
+HOMEPAGE = "https://github.com/k-bx/python-semver"
+BUGTRACKER = "https://github.com/k-bx/python-semver/issues"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+SRC_URI[md5sum] = "e98b5fb283ea84daa5195087de83ebf1"
+SRC_URI[sha256sum] = "fa0fe2722ee1c3f57eac478820c3a5ae2f624af8264cbdf9000c980ff7f75e3f"
+
+inherit pypi setuptools3 ptest
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_semver.py ${D}${PTEST_PATH}/
+}