aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:50 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit3692de1a1af1a919d99a2c6ef6b4c66e067f37b3 (patch)
treeca24e8632420ea206d163fb64da3866b025e485d /meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
parent581a31f56f108c61c4e0b7057845484ba82f0ee8 (diff)
downloadmeta-openembedded-contrib-3692de1a1af1a919d99a2c6ef6b4c66e067f37b3.tar.gz
python-sdnotify: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
index 377af12e16..221a8c8717 100644
--- a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
@@ -1,2 +1,18 @@
+HOMEPAGE = "https://github.com/bb4242/sdnotify"
+SUMMARY = "A pure Python implementation of systemd's service notification protocol (sd_notify)"
+
+DESCRIPTION = "\
+ sdnotify is a pure Python implementation of the systemd sd_notify protocol. \
+ This protocol can be used to inform systemd about service start-up completion, \
+ watchdog events, and other service status changes. \
+ Thus, this package can be used to write system services in Python that play nicely with systemd. \
+ "
+
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e"
+
+SRC_URI[md5sum] = "749ddca1c70be1697fecc443fb1fdb16"
+SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1"
+
inherit setuptools3 pypi
-require python-sdnotify.inc