aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:51 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commitcb3e4746dc3c1252cfb309326f89fcba06b6727f (patch)
treea424ae2a545aaaf3eabe313f4206763e91184a5c /meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
parent3692de1a1af1a919d99a2c6ef6b4c66e067f37b3 (diff)
downloadmeta-openembedded-contrib-cb3e4746dc3c1252cfb309326f89fcba06b6727f.tar.gz
python-scrypt: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
index f49665322e..7588fc54ba 100644
--- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
@@ -1,3 +1,24 @@
-inherit setuptools3 python3-dir
-require python-scrypt.inc
+DESCRIPTION = "Bindings for the scrypt key derivation function library"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc"
+HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview"
+SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
+
+SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56"
+SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}