aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@fujitsu.com>2021-08-04 09:23:53 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:37:42 -0700
commitea33b88613bb18897545175127c9e17ec1b2e9a7 (patch)
treeaab5e55203e23eb2de883edd9fb57491e2350860 /meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
parentc704cb00629dd66d20547b592b6add7ff6d2c1aa (diff)
downloadmeta-openembedded-contrib-ea33b88613bb18897545175127c9e17ec1b2e9a7.tar.gz
python3-robotframework: upgrade 4.0.3 -> 4.1
Add runtime dependency to resolve errors that occurred when import robot. Robot Framework 4.1 is a feature release with several nice enhancements, for example, to the continue-on-failure mode and argument conversion, as well as some bug fixes. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb b/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
new file mode 100644
index 0000000000..7c6c41af7c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "A Python generic test automation framework"
+DESCRIPTION = "Generic open source test atomation framework for acceptance\
+testing and acceptance test-driven development (ATDD). It has easy-to-use\
+tabular test data syntax and it utilizes the keyword-driven testing approach.\
+Its testing capabilities can be extended by test libraries implemented either\
+with Python or Java, and users can create new higher-level keywords from\
+existing ones using the same syntax that is used for creating test cases."
+HOMEPAGE = "http://robotframework.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE_EXT = "zip"
+
+SRC_URI[sha256sum] = "567f2a21f0906635e21d45fe3cb84a4809a12980c9f2706a8a5f65f40f6b4ccd"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"