aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-18 14:58:35 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-21 08:57:41 -0700
commitd7c8d85f959a693690bbf4d99102e8a68e78df13 (patch)
tree0daf6f64637333d51010ab94ac11e8d5732ca166 /meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb
parentea5d1e229898ba719818ccbab8e19010577f9ecc (diff)
downloadmeta-openembedded-contrib-d7c8d85f959a693690bbf4d99102e8a68e78df13.tar.gz
python3-rfc3339-validator: Upgrade 0.1.1 -> 0.1.2
Upgrade to release 0.1.2: - setup.py: move pytest-runner to test_requirements Patch has been removed from the recipe because it has been already upstreamed in the new release. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb
new file mode 100644
index 0000000000..e226e11b75
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A pure python RFC3339 validator"
+HOMEPAGE = "https://github.com/naimetti/rfc3339-validator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:"
+
+SRC_URI[md5sum] = "2c233007189d5ef21046cb2afac51a96"
+SRC_URI[sha256sum] = "c9659c3183488a1875c4d327c9873d9e92c54cdcd69dfbfae7546ad8b27baf9a"
+
+PYPI_PACKAGE = "rfc3339_validator"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"