aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2020-07-10 14:15:55 -0400
committerKhem Raj <raj.khem@gmail.com>2020-07-12 19:04:17 -0700
commited2e3e44fd3bb739d30583ee968232dccf0a1217 (patch)
treeeb48bb815aec0fd4ab4c9f6aa83e8c71d91c6a9b /meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb
parent0e38dbd16625773bbde31a049fedbb30b89f0ffa (diff)
downloadmeta-openembedded-contrib-ed2e3e44fd3bb739d30583ee968232dccf0a1217.tar.gz
python3-requests-toolbelt: add ptest
Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb
index 3beb397187..cb1bc607b3 100644
--- a/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb
@@ -5,12 +5,30 @@ AUTHOR = "Ian Cordasco, Cory Benfield"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=71760e0f1dda8cff91b0bc9246caf571"
+SRC_URI = "file://run-ptest \
+ "
+
SRC_URI[md5sum] = "b1509735c4b4cf95df2619facbc3672e"
SRC_URI[sha256sum] = "968089d4584ad4ad7c171454f0a5c6dac23971e9472521ea3b6d49d610aa6fc0"
-inherit setuptools3
-inherit pypi
+inherit pypi setuptools3 ptest
RDEPENDS_${PN} += " \
${PYTHON_PN}-requests (>=2.0.1) \
"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-betamax \
+ ${PYTHON_PN}-mock \
+ ${PYTHON_PN}-multiprocessing \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/setup.py ${D}${PTEST_PATH}
+ # remove test test_multipart_encoder.py as it fails,
+ # downloaded file is not supported
+ rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py
+}