aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-20 13:10:26 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-25 14:34:06 -0800
commit220d63cbc50fc54759e278727eee474b6d779a47 (patch)
treed5bc66de1d1c9d9951d07a46c493ba1fc5a2c4b4 /meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb
parentb9fce31173df46e556c66efb4c025111ccff3ed4 (diff)
downloadmeta-openembedded-contrib-220d63cbc50fc54759e278727eee474b6d779a47.tar.gz
python3-pyusb: Upgrade 1.1.0 -> 1.1.1
Upgrade to release 1.1.1: - Patch release that fixes a couple of bugs. Most notably it fixes compatibility with Python 3.9. - As of PyUSB 1.1.1 changes that break under Python 2.7 and 3.5 (both of which have reached end of life) are no longer considered regressions. License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb b/meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb
new file mode 100644
index 0000000000..a8c7031b65
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyusb_1.1.1.bb
@@ -0,0 +1,12 @@
+SUMMARY = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e64a29fcd3c3dd356a24e235dfcb3905"
+
+DEPENDS += "libusb1 ${PYTHON_PN}-setuptools-scm-native"
+
+SRC_URI[sha256sum] = "7d449ad916ce58aff60b89aae0b65ac130f289c24d6a5b7b317742eccffafc38"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"