aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:21:03 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit273ea761e1446e69c118280266a75737a3d42a85 (patch)
tree68728768d0e42547963bfe1f34b4edfeba98abc1 /meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
parenta874c6e2819ff1182a0e48941217c53c853c6b3c (diff)
downloadmeta-openembedded-contrib-273ea761e1446e69c118280266a75737a3d42a85.tar.gz
python-pytest-runner: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
index df56ba6d47..d00cd48739 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
@@ -1,2 +1,16 @@
-inherit setuptools3
-require python-pytest-runner.inc
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
+SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"