aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-03 17:38:19 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-05 10:26:11 -0800
commit53bc6fabbd23504f650c571ecc016727c40f2fcd (patch)
treed63786347b510bc64f2581478edd7937eacb8dd3 /meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
parent0f5d4a7ee97650484388c64f0be941b105bf1075 (diff)
downloadmeta-openembedded-contrib-53bc6fabbd23504f650c571ecc016727c40f2fcd.tar.gz
python3-pytest-html: Upgrade 2.1.1 -> 3.1.1
Upgrade to release 3.1.1: - Fix issue with reporting of missing CSS files - Stop attaching test reruns to final test report entries - Allow for report duration formatting - Respect --capture=no, --show-capture=no, and -s pytest flags - Make the Results table Links column sortable - Fix issue with missing image or video in extras - Fix attribute name for compatibility with pytest-xdist 2 - Post process HTML generation to allow teardown to appear in the HTML output License-Update: Following recent changes to README.rst, just use LICENSE downloaded from PyPI. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
new file mode 100644
index 0000000000..bd543d2f09
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "pytest plugin for generating html reports from test results"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+SRC_URI[sha256sum] = "3ee1cf319c913d19fe53aeb0bc400e7b0bc2dbeb477553733db1dad12eb75ee3"
+
+
+PYPI_PACKAGE = "pytest-html"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"