aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-02-14 15:18:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitd3dd0a52f3d6b9034effc110941b5adec630efb8 (patch)
tree56011b15483b9ed557a69efb395fee4ddd925ae2 /meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb
parent701290f6e4bbe70471e6f2be0a51540ac69f383b (diff)
downloadmeta-openembedded-contrib-d3dd0a52f3d6b9034effc110941b5adec630efb8.tar.gz
pytest-html: Add new package
pytest-html add support for outputing html reports from ptest runs. Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb b/meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb
new file mode 100644
index 0000000000..8ace29ed18
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-html_1.6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "pytest plugin for generating html reports from test results"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-html"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://../pytest-html.LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+# Per README.rst the license statement is fetched from
+# https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE
+SRC_URI += "https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE;name=license;downloadfilename=pytest-html.LICENSE"
+
+PYPI_PACKAGE = "pytest-html"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "ac956864a9b3392203dacd287ae450f0"
+SRC_URI[sha256sum] = "a359de04273239587bd1a15b29b2266daeaf56b7a13f8224bc4fb3ae0ba72c3f"
+SRC_URI[license.md5sum] = "5d425c8f3157dbf212db2ec53d9e5132"
+SRC_URI[license.sha256sum] = "2bfdca60adf803108d4c7f009000bea76ad00e621e163197881b0eaae91b530e"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-pytest"