aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-23 11:03:25 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-26 08:22:59 -0700
commitb339a51079c915c6c5eca120c0a36626641e3274 (patch)
tree28e45ef0bf1b7b3963918bab4981327221780330 /meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb
parent883dd439244d12f215006f8b3a7a50c8d068388e (diff)
downloadmeta-openembedded-contrib-b339a51079c915c6c5eca120c0a36626641e3274.tar.gz
python3-pytest-asyncio: Upgrade 0.14.0 -> 0.15.1
Upgrade to release 0.15.1: - Hotfix for errors while closing event loops while replacing them. - Add support for Python 3.9 - Abandon support for Python 3.5. If you still require support for Python 3.5, please use pytest-asyncio v0.14 or earlier. - Set unused_tcp_port_factory fixture scope to 'session'. - Properly close event loops when replacing them. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb
new file mode 100644
index 0000000000..1aa606b78b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.15.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[sha256sum] = "2564ceb9612bbd560d19ca4b41347b54e7835c2f792c504f698e05395ed63f6f"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"