aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-18 18:34:42 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-19 14:04:15 -0700
commit75d08193f05f1022fdb9e71870353f218ec2f9f9 (patch)
tree16f52d52db537704bcd001b0841f0427a6b9545b /meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb
parent53c9817e659b83b78e05571cf878c649eb5aee5c (diff)
downloadmeta-openembedded-contrib-75d08193f05f1022fdb9e71870353f218ec2f9f9.tar.gz
python3-pytest-asyncio: Upgrade 0.12.0 -> 0.14.0
Upgrade to release 0.14.0: - event_loop fixture behavior now is coherent on all scopes. License-Update: Use file LICENSE to check the license. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb
new file mode 100644
index 0000000000..1e94c25f7e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.14.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[md5sum] = "b63593bc08f445f6e3f14c34128a68ed"
+SRC_URI[sha256sum] = "9882c0c6b24429449f5f969a5158b528f39bde47dc32e85b9f0403965017e700"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"