aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-01 11:20:05 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-04 20:23:10 -0700
commit2ddacf6d4b199d594bfa0251888eee70ca71ec94 (patch)
treefe6865141cb55ed4156f9da13d178f4519197c44 /meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
parent42cae0315c80111fee192f1cdf09dd381df06490 (diff)
downloadmeta-openembedded-contrib-2ddacf6d4b199d594bfa0251888eee70ca71ec94.tar.gz
python3-pystemd: Upgrade 0.7.0 -> 0.8.0
Upgrade to release 0.8.0: - add initial support for python 3.7 and 3.8 - added options StandardOutputFile, StandardOutputFileToAppend, StandardErrorFile and StandardErrorFileToAppend to known unit signatures. - Added type stubs for pystemd.daemon, pystemd.dbuslib, pystemd.systemd1.Unit and pystemd.systemd1.Manager because we still "support python 3.4. - fix issue when char is unsigned, and <char *> -1 returns 255. - added slice_ option to pystemd.run to specify the cgroup where the unit is created. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
new file mode 100644
index 0000000000..e09b633f90
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python bindings for interacting with systemd over DBus"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[md5sum] = "f993739eca645749f18d4ccfd4a0fbf3"
+SRC_URI[sha256sum] = "cac2e42043ab28d43adf33dab493c6a3cf8a99794f824ae8af6d9cd6458b9972"
+
+DEPENDS = "systemd"
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+inherit pypi setuptools3 features_check
+
+BBCLASSEXTEND = "native"