aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-14 17:23:39 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-17 08:52:24 -0700
commitf3d8caa862a171d4db04eef44907058133882201 (patch)
treed49ae5a9da32944d3a80dbb53e1fbed2eeaa0f2e /meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb
parenta6c3620b63b9af0983fe6bfd44acc8cfcb3c36e6 (diff)
downloadmeta-openembedded-contrib-f3d8caa862a171d4db04eef44907058133882201.tar.gz
python3-pyroute2: Upgrade 0.5.18 -> 0.5.19
Upgrade to release 0.5.19: - ndb: fix default routes keys - mptcp: basic support - netlink: ext_ack support fix - tc: netem rate setting - NSPopen: fix fd leak Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb
new file mode 100644
index 0000000000..903bd6459c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.19.bb
@@ -0,0 +1,36 @@
+SUMMARY = "A pure Python netlink and Linux network configuration library"
+LICENSE = "GPLv2 & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
+
+SRC_URI[sha256sum] = "45460d12ed2a5caf272a357a3360b36d1e346f17afe1425b66fc21d70f462b29"
+
+inherit setuptools3 pypi ptest
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-unixadmin \
+"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-fcntl \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}